Déconnexion de la carte USBkey dans FSX

Servos / USBKeys / Stepmotor, etc...

Déconnexion de la carte USBkey dans FSX

Messagede FiX » Mer 1 Déc 2010 15:00

J'ai un petit problème qui doit plus être lié à FS qu'à la carte USBkey (j'espère):

J'ai donc testé ma carte USBkey pour la première fois sur mon module de pilote auto.
J'utilise le encoder_key.exe
J'ai branché la carte, elle est reconnue, j'ai branché 4 poussoirs , ils sont repérés etc...bref tout fonctionne très bien.
Lorsque j'utilise word ces 4 poussoirs me génèrent bien mes équivalents clavier ("I" "J" "K" et "L"), donc tout va bien jusque là.
Dans FSX j'assigne mes 4 poussoirs à des fonctions du pilote auto ( HDG / NAV / APR / AP), là encore tout va bien, il m'assigne les touches "MAJ + I" "MAJ+J" etc... Là encore tout va bien (c'est normal d'obtenir MAJ+ puisque la lettre assignée est en majuscule par défaut dans la config de l'USBkey)

Et là ça se corse: je lance un vol, je test mon pilote auto: fabuleux, ça fonctionne!! Je vois le pilote auto qui réagit à mon module (oui c'est toujours un grand moment d'émotion au début, mais vous, grand constructeurs de cockpit, ne vous souvenez peut être plus de cet instant magique de la première fois... sourirebis )
Bon, et là c'est le drame...au bout de 30sec ou peut être une minute, ça ne fonctionne plus.
Je sors de FS et je regarde ce que ça donne: Le panneau de onctrôle m'indique que la carte est toujours là, branchée, mais elle ne me génère plus de touches, ça ne réagit plus.
Je quite le programme et le relance: rien ne se passe
Je débranche et je rebranche la prise USB: ça refonctionne.

Je retourne dans FSX: ça refonctionne...et..paf, 20secondes plus tard rebelotte, ça ne marche plus!
Cette fois je ne sors même plus de FSX, je débranche et je rebranche directement la carte et ça refonctionne...pour 1 minute avant de se re-déconnecter et ainsi de suite!!

Je relance une nouvelle fois la carte et je retourne dans word pour faire mes essais en attendant de voir si ça finit par se bloquer: Et là, non, tout va très bien, j'ai laissé tourné le biniou au moins 1/2heure et j'ai régulièrement utilisé mes possoirs, ça fonctionne très bien, ça ne se déconnecte pas.

Donc je pense que ça ne vient pas de la crte, mais y'a un problème en rapport avec FS.
Mais quoi??? murrouge
Donc je quitte FSX, je relance
i7 2600k/P8P67pro/8Go PC3 17000/ATI 5850oc/velociraptor600Go/SSD 120Go/W7x64
https://www.facebook.com/cessna150.sim
Avatar de l’utilisateur
FiX
 
Messages: 4374
Inscription: 8/01/10
Localisation: Reims/Maubeuge

Re: Déconnexion de la carte USBkey dans FSX

Messagede FiX » Mer 1 Déc 2010 15:15

Je viens de remarquer également que une fois que la carte est "bloquée", si je ferme l'application encodeur_key.exe et que je la ré-ouvre, l'application ne s'ouvre pas, j'ai cliqué plus sieurs fois dessus, ça "cherche" un peu et puis...rien.
Et au moment où je déconnecte la prise USB là j'ai mon application qui s'ouvre! (en autant d'exemplaire que j'ai cliqué dessus précedemment...)

J'y comprends rien du tout! gratgrat








Euh...là, maintenant je crois qu'il est temps de dire... MAYDAY MAYDAY MAYDAY !!!! sourirebis
i7 2600k/P8P67pro/8Go PC3 17000/ATI 5850oc/velociraptor600Go/SSD 120Go/W7x64
https://www.facebook.com/cessna150.sim
Avatar de l’utilisateur
FiX
 
Messages: 4374
Inscription: 8/01/10
Localisation: Reims/Maubeuge

Re: Déconnexion de la carte USBkey dans FSX

Messagede stevelep » Mer 1 Déc 2010 20:50

Essaye une autre entrée USB, voir intercaler un HUB alimenté ?

Tu ne l'as pas alimentée, on ne doit pas l'alimenter.

BOB
Avatar de l’utilisateur
stevelep
Administrateur du site
 
Messages: 2028
Inscription: 27/03/09
Localisation: LSGN Neuchâtel, Suisse

Re: Déconnexion de la carte USBkey dans FSX

Messagede FiX » Jeu 2 Déc 2010 00:07

Non, je ne l'ai pas alimentée bien sûre.
J'ai essayé un autre port USB, ça ne change rien.
Elle fonctionne très bien, sauf lorsque je l'utilise avec FSX.
Je l'ai laissé tourner toute l'après-midi, elle marchait encore ce soir!
La preuve: IJJKLKI (ça c'est écrit avec les poussoirs de mon pilote auto... rigolus )

Ca commence à m'inquiéter cette affaire, pourquoi il n'y a que lorsque je démarre FSX que ça plante!?
i7 2600k/P8P67pro/8Go PC3 17000/ATI 5850oc/velociraptor600Go/SSD 120Go/W7x64
https://www.facebook.com/cessna150.sim
Avatar de l’utilisateur
FiX
 
Messages: 4374
Inscription: 8/01/10
Localisation: Reims/Maubeuge

Re: Déconnexion de la carte USBkey dans FSX

Messagede FiX » Sam 4 Déc 2010 03:17

Bon, bon...
Les tests que j'avais fait jusqu'à présent était réalisé sur un autre PC que celui qui servira au simu, où j'ai juste installé FSX et FSUIPC pour faire mes tests de cartes OC.
Là par contre je viens d'essayer la carte USBkey sur le PC du simu, et là, ça al'air de fonctionné (j'ai testé environ minutes de vol et la carte ne se bloque pas)
Alors, oui, tant mieux, ça veut dire que la crte n'a pas de soucis, ça n'est qu'un problème de config, m'enfin j'aimerais quand même bein comprendre pourquoi elle se bloque avec le FSX de l'autre PC!
i7 2600k/P8P67pro/8Go PC3 17000/ATI 5850oc/velociraptor600Go/SSD 120Go/W7x64
https://www.facebook.com/cessna150.sim
Avatar de l’utilisateur
FiX
 
Messages: 4374
Inscription: 8/01/10
Localisation: Reims/Maubeuge

Re: Déconnexion de la carte USBkey dans FSX

Messagede FiX » Dim 26 Déc 2010 21:02

Un petit up pour mon problème qui commence à devenir énervant... gratgrat
i7 2600k/P8P67pro/8Go PC3 17000/ATI 5850oc/velociraptor600Go/SSD 120Go/W7x64
https://www.facebook.com/cessna150.sim
Avatar de l’utilisateur
FiX
 
Messages: 4374
Inscription: 8/01/10
Localisation: Reims/Maubeuge

Re: Déconnexion de la carte USBkey dans FSX

Messagede GAILLARD » Lun 27 Déc 2010 08:12

Bonjour

Ca sent le manque d'alim ce truc la ..??

Quel différence il y a entre les deux PC ?
Quel difference il y a quand aux NB de periphériques branché entre les deux config...
As tu essayé de brancher ta carte à travers un Hub alimenté par un bloc alim ?

Supposons que ton alim de pc est trop juste ... si lorsque tu tourne FSX la carte graphique par expl , se met à produire des images avec une bonne cadence .. elle va consommer beaucoup sur l'alimentation du PC et là peut être que ta liaison USB n'a pas assez de courant pour assurer sont fonctionnement et ça se déconnecte ...d'ou plus de commandes...Il ne faut pas oublier que les processeurs de carte mère , ou graphique consomment sur les alim énormément , l'audio , les disques .. et que les alim souffrent. Elles sont dimensionnés pour les config de base ..

Les deux config ne sont certainement pas identiques en liaison matériel en interne (cartes sur les bus , disque dur etc...et en externe en fonction des périphériques branchés... le seul moyen de gerer cela est d'avoir un hub USB alimenté par un bloc alim spécifique de bonne qualité.
On a tendance à bien charger les config PC de base avec des add-on Hardware et software qui ajoute de la consommation et la limite est souvent atteinte sans pour cela avoir un "flag" au niveau du retour de trop de consommation.
D'une façon générale il faut toujours en matière de PC et d'add-on hardware sous USB placer un Hub alimenté entre le PC et l'Add-on du moins pour les cartes chaines de cartes A/D.... ceci est préconisé par tous les fabricants d'Add-on de cartes.
bonne chasse aux Ampères ... sur une liaison USB il y a une limitation à 1.5A ... ( donc 7.5 W sous 5V max) mais ça ,plus ça, plus ça etc... l'alim du PC est en limite..
C'ets une piste
Le rêve n'a pas de limite
Avatar de l’utilisateur
GAILLARD
 
Messages: 1487
Inscription: 19/04/09
Localisation: sud Ile de France

Re: Déconnexion de la carte USBkey dans FSX

Messagede FiX » Mar 28 Déc 2010 00:19

Merci gaillard,
Ca aurait effectivement pu être une piste, je vais essayer de trouver un hub alimenté pour écarter totalement le problème, mais ça m'étonnerait quand même.
J'ai l'impression qu'il y a vraiment un blocage "software" dès que je démarre FSX.
Et puis surtout comme je le disais plus haut :
"Je viens de remarquer également que une fois que la carte est "bloquée", si je ferme l'application encodeur_key.exe et que je la ré-ouvre, l'application ne s'ouvre pas, j'ai cliqué plus sieurs fois dessus, ça "cherche" un peu et puis...rien.
Et au moment où je déconnecte la prise USB là j'ai mon application qui s'ouvre! (en autant d'exemplaire que j'ai cliqué dessus précedemment...)", ça fait plus penser à un soucis de soft que de sous-alim.

J'ai testé sur tous les ports USB (en laissant tous les autres libres), c'est pareil.
J'ai essayé d'autres applications graphiques consommatrices de GPU: l'USBkey fonctionne très bien.
Et dès que je démarre FSX, même si je ne lance pas de vol (je reste dans le menu), donc très peu de conso, paf, ça se bloque au bout de 30secondes!
J'ai également essayé de voler en mode fenêtré mais en réduisant la fenêtre à un tout petit carré de quelques cm (là aussi ça réduit énormément la conso graphique)=> ça se bloque quand même...
Et puis une autre carte comme la bodnar n'a aucun soucis en mettant FSX à fond en 1920*1080 à 5FPS à faire ramer la CG au possible...
Donc ça ne semble pas venir de l'alim... gratgrat

Pour les PC:

Le PC de mon simu (celui sur lequel l'USBkey a bien fonctionné) est celui décrit dans ma signature, c'est pas du core i7, mais c'est déjà une config qui tourne pas mal avec des composants corrects et une bonne alim, donc pas de soucis hardware.
Le PC sur lequel je veux faire mes essais (celui sur lequel ça se bloque) est mon PC de "bureau", un compaq quadcore qui doit avoir un peu plus d'un an, c'est pas terrible mais c'est pas une antiquité non plus. Il est en widows vista.
Il n'y a aucun périph branché dessus lors de mes test à part une clef wifi. Sinon en temps normal il y a en plus une tablette graphique et un DD externe.


Il y a autre chose, je ne sais pas si ça peut avoir un rapport, mais on ne sait jamais:
J'utilise aussi ce PC pour faire des tests de différentes gauges stand-alone (jeehel, flyfrog, ATR72, jaycosim...) et j'ai remarqué que j'ai également un problème de déconnexion des gauges (sauf celles de flyfrog, pourqoi!!?? gratgrat ) au bout de 20/30secondes de vol, comme la carte usbkey...
i7 2600k/P8P67pro/8Go PC3 17000/ATI 5850oc/velociraptor600Go/SSD 120Go/W7x64
https://www.facebook.com/cessna150.sim
Avatar de l’utilisateur
FiX
 
Messages: 4374
Inscription: 8/01/10
Localisation: Reims/Maubeuge

Re: Déconnexion de la carte USBkey dans FSX

Messagede GAILLARD » Mar 28 Déc 2010 23:41

Bien les tests

Je ne peux pas te dire si c'est la solution mais à chaque fois que nous avons eu des pb bizarres de comportement de soft au club de vol virtuel , cela venait des alim... soit l'alim du PC trop juste et le comportement du PC n'est pas toujours comprehensible... la dernière fois nous avons galeré 2 semaines ...comportement du PC pas net ... nous avons passé notre alim PC à la taille au dessus et la miracle plus de pb

Personnellement c'est un point ou je ne fait pas de concessions ... je viens de monter un PC de course , avec un I7 960 avec une carte graphique Sapphyre HD5870-1024 une carte mere ASUS P6X58D-E, trois disques dur dont deux velociraptor de 600 GO et un autre de 1T0 WD, 6GO de memoire, W7 64 bit dans une tour avec 4 ventillateur et un radiateur de course pour le processeur et j'ai mis une alim de 1000W ANTEC. Ce PC va tourner FSX sous W7 sur mon A320 ( gestion des images externes du simulateur) , les autres logiciels (avionique et A/D) vont tourner sur XP sur 6 PC supplementaires en réseau... je suis contraint de changer le PC de visu externe pour tourner les logiciels qui arrivent ... entre autre ceux d'Aérosoft (OSLO demande 4G0 à avec XP ce n'est pas possible) et en plus j'aurai FS ALTITUDE pour l'Europe

Les pb viennent souvent des alim...

Pour les USB en simulation , toujours passer par des HUB alimentés surtout sur des chaines de cartes A/D...(c'est l'assurance fonctionnement) ... autre point sur les USB ne jamais changer le port physique qui a servi à faire la première installation d'un logiciel .... (en cas de démontage : faire une check list pour le remontage pour assurer les branchements aux memes endroits)

Tout ce que je te dis c'est du vécu depuis 2 ans 1/2 que je ballade mon simu...

Maintenant il y a peut être une incompatibilité soft avec FSX et les autres logiciels ... peut être faut il consulter des "forum" concernant ces logiciels face à FSX

Bonne soirée

GG
Le rêve n'a pas de limite
Avatar de l’utilisateur
GAILLARD
 
Messages: 1487
Inscription: 19/04/09
Localisation: sud Ile de France

Re: Déconnexion de la carte USBkey dans FSX

Messagede FiX » Mer 29 Déc 2010 01:24

Merci pour ta réponse Gaillard.
Et bien je sens que c'est mal barré pour ce PC qui de toute façon ne recevra pas de nouvelle alim.
Le principal étant tout de même que ça fonctionne sur le PC du simu.
Et comme de toute façon je compte également passer d'ici peu à une config plus musclée (I7 950 / P6TdeluxeV2/6Go/radeon 5850/ SSD), je ne lésinerais pas sur l'alim en espérant ne plus avoir ces problèmes.

Pour l'emplacement des USB, alors c'est effectivement quelquechose qui m'a toujours intrigué, je sais qu'il ya certain périph qui n'aiment pas du tout être déplacé et d'autres qui le supportent bien.
J'aimerais bien un jour comprendre pourquoi...
i7 2600k/P8P67pro/8Go PC3 17000/ATI 5850oc/velociraptor600Go/SSD 120Go/W7x64
https://www.facebook.com/cessna150.sim
Avatar de l’utilisateur
FiX
 
Messages: 4374
Inscription: 8/01/10
Localisation: Reims/Maubeuge

Suivante

Retourner vers Autres cartes Opencockpits





Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités